JVLIVS CAESAR MODS FORUM
Estimado usuario invitado: Si se registra/conecta podrá tener la mejor ventaja, postear en el foro, ya que los invitados solo pueden leer.

JVLIVS CAESAR MODS FORUM

Imperium III Mods Forvm. Último Mod - MCI 9.0!
 
ÍndiceÍndice  FAQFAQ  BuscarBuscar  RegistrarseRegistrarse  ConectarseConectarse  

Comparte | 
 

 Problema con TimeWithoutWalking

Ver el tema anterior Ver el tema siguiente Ir abajo 
AutorMensaje
molerotoni
General
General
avatar

Cantidad de envíos : 94
Edad : 22
Location : Valencia, España
Reputación : 25
Fecha de inscripción : 03/07/2015

MensajeTema: Problema con TimeWithoutWalking   Miér Sep 02, 2015 3:31 pm

No consigo que me funcione, es decir, quiero que si lleva 5 segundos sin moverse realice una acción, pero no hace nada. Con el de TimeWithoutAttack no tengo problema alguno.
   if(lobo.TimeWithoutWalking>5000)//esto no va
    lobo.Goto(owner.pos,0,0,false,0);
   if(lobo.TimeWithoutAttack>5000)//esto sí va
    lobo.Goto(owner.pos,0,0,false,0);
Volver arriba Ir abajo
Darth_Skaywalker
Moderador
Moderador
avatar

Cantidad de envíos : 764
Edad : 19
Location : Córdoba, España
Reputación : 60
Fecha de inscripción : 28/11/2009

MensajeTema: Re: Problema con TimeWithoutWalking   Miér Sep 02, 2015 11:40 pm

Yo no estoy muy familiarizado del todo con los scripts del editor, pero ese existe? Por ejemplo que en vez de TimeWithoutWalking, sea TimeWithoutWalk, no se si me explico. Seguramente no sea lo que yo digo, pero es que no estoy muy familiarizado, saludos!

_________________
Estudiante de informática y aficionado a la seguridad informática.
Antes de postear leete las [Tienes que estar registrado y conectado para ver este vínculo]. Y si necesitas ayuda, busca que no exista ya un tema similar.
Recomiendo encarecidamente leer esto:
[Tienes que estar registrado y conectado para ver este vínculo]
-------
@RafaSojo en telegram
Volver arriba Ir abajo
http://editor-imperium.webcindario.com/
molerotoni
General
General
avatar

Cantidad de envíos : 94
Edad : 22
Location : Valencia, España
Reputación : 25
Fecha de inscripción : 03/07/2015

MensajeTema: Re: Problema con TimeWithoutWalking   Jue Sep 03, 2015 2:24 pm

Ese lo he sacado del dump_try. Existir existe, que función e es otra historia. Y TimeWithoutWalk no sale en el dump_try, aunque lo probaré igual.
Volver arriba Ir abajo
Camarada
Equipo de Diseño
Equipo de Diseño
avatar

Cantidad de envíos : 286
Location : España
Reputación : 115
Fecha de inscripción : 01/05/2010

MensajeTema: Re: Problema con TimeWithoutWalking   Jue Sep 03, 2015 5:57 pm

Hola a tod@s , la orden TimeWithoutWalking a mi tampoco me funciona ,  a lo mejor no funciona bien , aunque lo más probable es que no se use como se debe .
He probado a meter en una variable el valor que guarda el TimeWithoutWalking cuando la unidad está parada , y el valor es siempre "0" , si ese cero es el tiempo ,  la orden no indica el tiempo que la unidad está parada , ...... al no ser que esa orden no reconozca el movimiento IDLE como unidad parada.

el comando que he usado para allar ésto es :

     tiempo = u.TimeWithoutWalking();
     pr(tiempo);


Suerte
Volver arriba Ir abajo
Contenido patrocinado




MensajeTema: Re: Problema con TimeWithoutWalking   

Volver arriba Ir abajo
 
Problema con TimeWithoutWalking
Ver el tema anterior Ver el tema siguiente Volver arriba 
Página 1 de 1.
 Temas similares
-
» TENgo PROBLEMA CON HEADSET MW2
» problema hoja barbara
» Problema Urgente con el hamachi!
» IMPOSTANTISIMO PROBLEMA HEADSET PS3
» (Solucionado) Problema con los retrovisores

Permisos de este foro:No puedes responder a temas en este foro.
JVLIVS CAESAR MODS FORUM :: Modding en General :: Modding en General :: Edición de Scripts-
Cambiar a: